Wifi connection not working


#1

Hi

I was given an egg from work to try to set up at home (as I think there were problems there).

I managed to connect it to my laptop and to get the plugin working in Chrome

I tried to set up Wifi connection and it failed. I assumed they’s maye be been trying options at work, so I did a

restore defaults

I dicsonnected and reconnected and tried again entering my wifi ssid and password

I know the SSID is correct as I have checked it - and this laptop and my phone are running off it.

When I connect I get

±-----------------------------------+
| Welcome to Air Quality Egg 2.0 |
| NO2 / CO Sensor Suite |
| Firmware Version 2.1.9 |
±-----------------------------------+
Compiled on: Sep 21 2016 13:41:28
Egg Serial Number: egg00802f7dc4080132

Info: Tiny Watchdog Initialization…OK.
Info: Slot Select Pins Initialization…OK.
Info: SPI Flash Initialization…OK.
Info: SD Card Initialization…Fail.
Info: Current firmware signature: 342996 48051
Info: SHT25 Initialization…OK.
Info: NO2 Sensor AFE Initialization…OK.
Info: NO2 Sensor ADC Initialization…OK.
Info: CO Sensor AFE Initialization…OK.
Info: CO Sensor ADC Initialization…OK.
Info: RTC Initialization…Fail
Info: ESP8266 Initialization…Failed.
Info: Startup config integrity check passed, but mirrored config differs, attempting to restore from mirrored configuration.
Error: Mirrored configuration is not valid, cannot restore to last valid configuration.
Enter ‘aqe’ for CONFIG mode.
OPERATIONAL mode automatically begins after 12 secs of no input.

It says it scans for networks but finds none.

Any ideas?

Thanks

Ian


#2

Hi Ian, please can you try using a different terminal program than the browser, for example Arduino Serial Monitor or PuTTY?


#3

Hi,

yes can do using Putty - can you point me to instructions to do that please?

Thanks

Ian


#4

The instructions are no different than using the web-based serial monitor, except that you typically have to figure out what your COM port name is assigned by your operating system. Spark Fun has a pretty good overview of Serial Terminal Basics.

In a nutshell, connect to the Egg’s USB serial port using 115200 baud, 8 data bits, 1 stop bit, and no parity. Make sure you have carriage return or new lines enabled, but that should be the default in most cases. Then type aqe and hit enter and you’ll be at the Egg’s command line interface where you can configure the Egg as described in the manual. To be on the safe side, I would recommend initiating your configuration session with the command restore defaults and press enter, to ensure you’re starting from a clean slate.

Please let me know if you need more clarification and how it goes?


#5

Hi. Used the Arduino serial per the video instructions, Now working! Thanks


#6

Hi

When I try to register it I get an Egg not found message (as here Particulate egg gives an "egg not found" message even though it is connected to the internet )

It appears to be running.My ID is as in the first message above.

Ian


#7

Cool, glad that worked for you! Please try again with the Serial Number, looks like for some reason we failed to pre-register it for you, should work now.


#8

Hi

Still getting the same ‘egg not found’ message.

Ian


#9

Hm… ya I see that too now. Must be something going on with the Xively service, The map isn’t even showing up for me right now. I’d say check back later today. We are way behind on migrating that page content away from Xively, it’s the last vestigial organ of Egg v1.


#10

@iwatt Sorry for the delay, but I think it’s up and running again now if you want to give it another go. Let me know if you have any trouble.


#11

hi Ian got this AQE working at home; I’m now trying the same AQE in the office - it appears that the AQE is making ‘calls’ digital ocean and amazon and gets an unresolved ip. I’m guessing that digital ocean is some cloud service; however, I’m unclear why amazon technologies in Dublin using 2 different IP addresses - what is this?


#12

Hi @mwyllie, let me start by emphasizing that we are here to help in any way we can. Air Quality Eggs talk to (at most) three different servers in the course of their operation. The first two are only contacted during startup.

  1. The Egg checks for ‘over-the-air’ (OTA) firmware updates (by default) at update.wickeddevice.com. The request one or two files from this site; one small file to verify the signature of the firmware they are already running, and one to update their firmware image if their current signature doesn’t match (so usually it will only be one small file fetched). Eggs can be configured to skip this step by issuing the command updatesrv disable using the command line interface; they can even be configured to reach out to a different update server using the same command. At this time, update.wickeddevice.com is hosted on a Digital Ocean server. The update server is a standard web server operating on port 80.

  2. The Egg attempts to synchronize its internal clock with a Network Time Protocol (NTP) server if that capability is enabled. By default this is not enabled, and the capability is described in a bit more detail in this blog post. At this time, the default NTP server the Egg talks to is pool.ntp.org, and in the next firmware update, this is expected to change to 0.airqualityegg.pool.ntp.org. Neither of these are servers that we administer. You can also configure an Egg to talk to an NTP server of your choosing, using the command ntpsrv your.ntp.server.com. NTP is a UDP protocol operating on port 123.

  3. After startup, the Egg communicates with an MQTT server to publish its data to the internet periodically. By default messages are currently published every 5 seconds on most models, but can be configured differently through the sampling command at the command line interface. One message is published per sensor type / topic, depending on model that is 4 or 5 small messages being published every period. I’m planning to change this default behavior to publish once a minute in the next firmware release. Currently, all eggs publish to the OpenSensors.io MQTT broker at mqtt.opensensors.io. I believe OpenSensors hosts their services on Amazon AWS, and MQTT is a TCP protocol operating on port 1883.

So I think what you see there is in line with expectations as to which servers the Egg calls. If your Egg works at home and does not appear to work in an “enterprise” network context, this is typically because of additional security measures being in place on that network. The most common cause I’ve seen has been the presence of “captive portal” technology.

If a foreign computer comes onto your network and attempts to use the internet (e.g. browses to google.com), and it is confronted by a page asking you to “log in” or otherwise accept terms of service before being allowed to reach the broader internet, that’s what I mean by a captive portal. The Egg is not equipped to handle such a scenario, but most such systems allow a network administrator to make exceptions for allowing “headless” devices by registering their MAC addresses in a “white list.” You can get your Egg’s MAC address from the command line interface from the Network Settings section of the configuration logs that are reported after typing aqe or get settings, or you can type get mac to cut to the chase. It will be a string of pairs of letters (a-f) and numbers, separated by colons (e.g. a1:c2:eb:78:99:2d).

Another thing that might be helpful is that, if your network administrator requires it / wants to take advantage of it, an Egg can be assigned to use Static IP configuration instead of Dynamic (DHCP) configuration (which it uses by default). You can do this using the staticip command from the command line interface which requires you to provide: Static IP address, Netmask, Default Gateway IP address, and DNS server IP address.

Hopefully this is helpful, but please don’t hesitate to follow up here or with an email to support@wickeddevice.com.


#13

2 things can you pre-register all my devices (6) on opensensors.io - this was not done - I’ve tried creating 2 devices but the MQTT service keeps rejecting my account details either the password is wrong or the username is wrong - I assume it uses my name then finds the client ID device then the password for the device also I notice the ‘password’ for the device is not encrypted on the MQTT service - password for the device is plain text. Please advise.


#14

@mwyllie I think we should try and set up a Skype conversation to help sort out your problem. Please can you contact support at wickeddevice dot com and we can find a time that is workable? Too much complexity and opportunity to misunderstand each other in a written medium.


#15

Confirming that we have successfully resolved this issue over email, and this ticket is closed.