Turner Onner - Can't connect to IP address


Hello, My son is creating the Turner Onner for a homeschooling project. He got all the way to the end, was given an IP address, but can’t connect to it in any browser. What do we do from here? He wants to finish this project for a grade. Any help would be appreciated. Thanks.


If he got all the way to obtaining an IP address he should be home free… is the computer he’s using a browser to connect with on the same network as the NodeMCU connected to? That’s required for it to work… you could also try connecting with a phone web browser given that the phone is connected to the same Wi-Fi network as the NodeMCU.


Yes, we can get an IP address, but then can’t connect to the server. The device and browser are on the same wifi network. Any other suggestions?


Hm… I haven’t seen that happen before. @Dirk might have some other ideas? One other thing I would have you check is whether you can “ping” the NodeMCU by its IP address. This is done using a command shell (i.e. Start > Run > cmd in Windows, term in MacOS and Linux) to execute something like: ping If you can ping it, you should be able to navigate to in a browser.


Okay, we were trying to do this on my son’s Windows laptop. We just tried it on my Mac and have a new problem. When trying to upload the code, we got the following errors:

Arduino: 1.8.1 (Mac OS X), Board: “NodeMCU 1.0 (ESP-12E Module), 80 MHz, 115200, 4M (3M SPIFFS)”

Sketch uses 253635 bytes (24%) of program storage space. Maximum is 1044464 bytes.
Global variables use 40988 bytes (50%) of dynamic memory, leaving 40932 bytes for local variables. Maximum is 81920 bytes.
warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed

Hmmm - I just got the same error after I disconnected the Turner Onner from the Mac, so that tells me there’s no communication between the Mac and the Turner Onner.


Also, the IP address we were given on the laptop setup was not Is that okay?


On a Mac, I believe you need to install a USB driver as per https://github.com/nodemcu/nodemcu-devkit/wiki/Getting-Started-on-OSX


That IP address was just representative, not literal


I gave up on trying it with the Mac. Once again, I am able to connect on my Dell laptop, and I get an IP address in the serial monitor. When I type that address into a web browser, I get “Unable to connect.” The network is the same. Still need help to trouble shoot this. My son is anxious to get it working ha ha!

I just tried pinging it. Here are the results:


Here is the serial monitor:


You are getting sub millisecond ping replies from the NodeMCU… I can’t think of any reason why you wouldn’t be able to reach it with a web browser. Have you tried with different browsers (e.g. Chrome? Firefox?)