Server working? Egg not registering...help please!


#1

Hi,

I´ve a few issues trying to use eggs: At the moment, I´m trying to get 2 running:
CO/NO2: (egg008022c2b2180141) and a PM (egg008028c02408152).

The CO/NO2 egg was running fine yesterday, but now will not connect to mqtt server. I´ve reset wifi ssid and pwd, but to no avail.

The PM egg is running, but having registered egg with both AQE site and opensensors.io, the data is not yet available on either site. May be problem recognising serial number?

Also, the download tool is just hanging for me: I tried to download one day of data from one egg, no luck so far.

Please advise,

Liz


#2

Hi, Liz!

I have an easy fix for your particulate egg problem-- the serial number is actually egg008028c024080152 (it appears that you may have been missing a zero in the last group of four digits). I was able to connect to that egg and can see that it is pushing data to OpenSensors, and I was also able to retrieve data for that egg via the download site just now, so the particulate egg seems to be working.

I found that I can’t see data from the CO/NO2 egg via our OpenSensors.io account-- I believe that may be because it was “claimed” by NUIG at some point in the past. That shouldn’t have affected the operation, however-- if both eggs are reporting that they are properly connected to the network, then they should both be sending data to OpenSensors.io. Yodit @ OpenSensors support reported early this morning that everything was looking fine on their end, and I take that to mean that they are able to see your data for that egg coming in? I’ll do a bit more research and see what I can find out.

I have a suspicion that the CO/NO2 egg may not be connecting to WiFi. Could you send me an email with a list of the things you see on the front panel display when you plug it in? I’m particularly interested in the firmware version, but I’d also like to know if the egg eventually enters online mode and begins reporting data.

Thanks,
Chris Westling
Wicked Device
chris@wickeddevice.com


#3

Hi Chris, thanks for your reply. I now have a new problem: while connecting the CONO2 egg in order to try to configure to new wifi settings, I dont get past CC3000 initialization, hangs on that. Any idea? Iḿ using Putty to connect to egg. The serial connector in Browser doesn work for me for some reason. Thanks


#4

Hi Liz,

Please can you try not using the Browser to configure the Egg, and instead use the Arduino Serial monitor? You can download Arduino at http://arduino.cc/download and access the Serial Monitor from the Tools menu.

I’ll also offer you that you can send your Egg back to us for a tech refresh. We’ll replace your Wi-Fi hardware with our newer chip-set and re-calibrate your Egg using our improved temperature profiling calibration process as well. If you want to do that, please email support at wickeddevice dot com to arrange an RMA. I’d recommend it, as the new Wi-Fi hardware represents a significant improvement.


#5

Ok, Thanks, I´ll get in touch with customer service. However, why use arduino instead of Putty? Putty worked fine before,


#6

Liz, PuTTY is fine too. I’m just worried about the web-based terminal. Nothing confirmed yet. -Vic


#7

So, I want to go back to first egg, the PM (egg008028c024080152) - still not displaying anything on opensensors.io - waiting for event - hence, nothing on AQE website. You mentioned originally that data was indeed publishing to opensensors, but I can’t see the data anywhere. Help would be appreciated. On the other dead egg, I’m awaiting word from support@wickeddevice.com re returning the merch.

Cheers.


#8

Hi @eiliscoleman, I just entered that serial number into https://airqualityegg.wickeddevice.com/download and entered in 1 day for the duration and I got a successful download. I’m not sure what you mean when you say its not displaying anything on opensensors.io (as that is where the download tool draws the data from). If you want to visualize your data, my current recommendation is to download the period of time you want to visualize using https://airqualityegg.wickeddevice.com/download, then upload the CSV data you want to visualize to https://airqualityegg.wickeddevice.com/multiplot. There’s also an experimental dashboard I’ve been working on at https://airqualityegg.wickeddevice.com/dashboard/#/egg/your_serial_number, for example: https://airqualityegg.wickeddevice.com/dashboard/#/egg/egg008028c024080152. It’s a bit rough around the edges, but pretty cool anyway, I think.


#9

Thanks, Victor - I saw the data! great - so is there a way I can download direct from Opensensors? For some reason the browser download tool is a little slow, and previously it didn’t work for me (just loaded indefinitely). But anyway, the data is publishing, that’s good news. Thanks.


#10

@eiliscoleman if you are prepared to write software, you can use the OpenSensors.io API, but really that’s all I’m doing with the Download Tool (source code). To the best of my knowledge OpenSensors.io doesn’t have plans to create a front-end experience for non-developers. That being said the team here at Wicked Device and I are working towards improving accessibility of data.

For what it’s worth, I think some of the problems you experienced recently may have been related to OpenSensors.io development team working on improvements to the performance of their API service that inadvertently introduced a bug on their end (that they identified and resolved based on our feedback). If you ever experience unexpected or frustrating behavior, please let us know. If we can do anything about it we will, and if there is nothing we can do directly, we’ll escalate it.


#11

Hi There,

Can you help ?
My egg IDs
Number 1 00802d945f9b0102
Number 2 647907061

Eggs not showing any data here :
http://airqualityegg.com/egg/00802d945f9b0102
http://airqualityegg.com/egg/647907061

nor here
https://airqualityegg.wickeddevice.com/dashboard/#/egg/00802d945f9b0102
https://airqualityegg.wickeddevice.com/dashboard/#/egg/647907061

nor here :
https://personal.xively.com/feeds/816474241
https://personal.xively.com/feeds/647907061

Last question : any widge available to display this on a blog ? www.mypollutionfacts.com

Your help is much appreciated,

Best,

Nicolas


#12

You need to have the full serial number including “egg” in the URL for the dashboard, i.e.: https://airqualityegg.wickeddevice.com/dashboard/#/egg/egg00802d945f9b0102

You can also download data from your Egg in CSV format from https://airqualityegg.wickeddevice.com/download by filling in the form and specifying a period of time to download. You can also upload CSV data acquired in this way to an online plotting tool we developed at https://airqualityegg.wickeddevice.com/multiplot

The other URLs you suggested are defunct for the moment. We’re doing a bunch of work over the next couple of months to unify the tools and data experience. I don’t have on my radar at the moment an embed-able widget, but would be happy to hear your suggestion about what you might like to see in this respect and we can see what we can do to support that. Best would be to email suggestions like that to support at wickeddevice dot com.

We are working on making this more accessible.


#13

Guys, awesome live graphs. Thanks again for your speedy feedback !

Only good problem: there seems to be no pollution at all in my area to measure ?

Concentrations of PM 2.5 < 1 or an AQI of 4
https://airqualityegg.wickeddevice.com/dashboard/#/egg/egg00802d945f9b0102
https://airqualityegg.wickeddevice.com/dashboard/#/egg/egg008029373a1b0102

against AQICN along a road in the same city < 5 km away
Concentration of PM2.5 = 9 or an AQI of 38

How can I test if the sensors are well calibrated ?

Thanks

All the best,

Nicolas


#14

A quick heads up, the dashboard tools will be unavailable for the next week or so while we do some work to improve the overall integration of our websites. Apologies for the inconvenience.

Also sorry for the delay in responding to your other questions. For our current particulate sensors, we do a calibration to ensure that in clean / filtered air the reported values are at or around zero.

We also perform a test step to make sure that, in a closed environment, with the introduction of smoke burning incense, the sensors respond in substantially, but we haven’t got a span calibration approach at the moment. That is to say, we don’t have a way of creating a consistent and known particulate concentration by which to normalize the span response of each sensor. If you have ideas on how we might accomplish that, I would be very interested to hear them!


#15

Hi @Nicolas_GIRAUDON et al. Just wanted to make sure you got the message that the realtime graphs functionality has finally been integrated into https://airqualityegg.wickeddevice.com/portal