Problems adding Air Quality Egg 2


#1

Hi all,
I recently purchased an Air Quality Egg 2. I have followed the instructions as given (i.e. using the serial console, defining the wireless SSID and password before exiting, unplugging from the computer and plug into a mains-USB adapter).

I can ping the device so I am know the egg is connected to the network. However, when I then try to add my egg from http://airquality egg.com using the serial ID given in my user manual (i.e. something like egg1234567890123456), the web page returns ‘egg not found’.

I have noticed I am getting an error message in the console output which I have added below. Here is the output (note the error message 'Error: Couldn’t resolve ‘update.wickeddevice.com’). (note I have changed the serial ID displayed in the output just in case this needs to be kept private).

Any ideas would be much appreciated. For example, do I need to change any settings on my router (e.g. port forwarding)? Do I need to update my firmware? Is there a known bug inhibiting the new AQE devices to register with the ‘cloud’?

Thanks

Robbie

CONSOLE OUTPUT:

Serial Monitor:

Port: Speed: Disconnect
Warning! Because of a known bug on Chrome, you should press the disconnect button before physically disconnecting your device.
Or else the connection with the serial monitor will stay open until you restart your browser.

±-----------------------------------+
| Welcome to Air Quality Egg 2.0 |
| NO2 / CO Sensor Suite |
| Firmware Version 2.0.4 |
±-----------------------------------+
Compiled on: Aug 24 2015 12:47:06
Egg Serial Number: egg1234567890123456

Info: Tiny Watchdog Initialization…OK.
Info: Slot Select Pins Initialization…OK.
Info: SPI Flash Initialization…OK.
Info: SD Card Initialization…Fail.
Info: Current firmware signature: 346044 18705
Info: SHT25 Initialization…OK.
Info: NO2 Sensor AFE Initialization…OK.
Info: NO2 Sensor ADC Initialization…OK.
Info: CO Sensor AFE Initialization…OK.
Info: CO Sensor ADC Initialization…OK.
Info: RTC Initialization…Fail.
Info: CC3000 Initialization…OK.
Enter ‘aqe’ for CONFIG mode.
OPERATIONAL mode automatically begins after 12 secs of no input.
11…10…9…8…7…6…5…4…3…2…1…0…
-~=* In OPERATIONAL Mode *=~-
Info: Beginning Network Scan…
Info: Network Scan found 8 networks
Info: Found Access Point “scoobydo”, RSSI = 83
Info: Connecting to Access Point with SSID “scoobydo”…OK.
Info: Request DHCP…OK.
Info: IP Addr: 192.168.1.115
Info: Netmask: 255.255.255.0
Info: Gateway: 192.168.1.1
Info: DHCPsrv: 192.168.1.1
Info: DNSserv: 192.168.1.1
Info: Mirrored configuration already matches current configuration.
Error: Couldn’t resolve 'update.wickeddevice.com
Info: Resolved “opensensors.io” to IP address 52.19.195.193
Info: Connecting to MQTT Broker with Client ID “egg1234567890123456” using Authentication…OK.
Info: Sampling Sensors @ 70685
csv: Timestamp,Temperature[degC],Humidity[percent],NO2[ppb],CO[ppm],NO2[V],CO[V]
csv: 01/01/1970 00:01:11,—,---,—,---,0.000000,0.000000
Info: MQTT publishing to topic /orgs/wd/aqe/heartbeat…OK.
Info: Watchdog Pet.
Info: Watchdog Pet.
Info: Watchdog Pet.
Info: Watchdog Pet.
Info: Watchdog Pet.
Info: Sampling Sensors @ 75685
csv: 01/01/1970 00:01:16,—,---,—,---,0.000000,0.000000
Info: MQTT publishing to topic /orgs/wd/aqe/heartbeat…OK.
Info: Watchdog Pet.
Info: Watchdog Pet.
Info: Watchdog Pet.
Info: Watchdog Pet.
Info: Sampling Sensors @ 80685
csv: 01/01/1970 00:01:21,—,---,—,---,0.000000,0.000000
Info: MQTT publishing to topic /orgs/wd/aqe/heartbeat…OK.
Info: Watchdog Pet.
Info: Watchdog Pet.
Info: Watchdog Pet.
Info: Watchdog Pet.
Info: Sampling Sensors @ 85693
csv: 01/01/1970 00:01:26,—,---,—,---,0.000000,0.000000
Info: MQTT publishing to topic /orgs/wd/aqe/heartbeat…OK.
Info: Watchdog Pet.
Info: Watchdog Pet.
Info: Watchdog Pet.
Info: Watchdog Pet.
Info: Sampling Sensors @ 90693
csv: 01/01/1970 00:01:31,—,---,—,---,0.000000,0.000000
Info: MQTT publishing to topic /orgs/wd/aqe/heartbeat…OK.
Info: Watchdog Pet.
Info: Watchdog Pet.
Info: Watchdog Pet.
Info: Watchdog Pet.


#2

Hi Robbie,

The good news is the output from your Egg appears to be completely normal (for an Egg without the Offline Data Logging package installed - hence the SD and RTC fail messages). It looks to be connecting to the network and opensensors.io and publishing data like a champ. I just re-registered your Serial Number (looked you up in the production logs), so please can you give it another try? Should be good to go now.

Kind Regards,
Vic


#3

Excellent. That worked a treat. Thanks for the very quick turn around


#4

Quick question: roughly after how long should it take before the measurements from my air quality egg appear on the website? And how often are they updated?


#5

It should start publishing in about 3-5 minutes after it starts up, and ti should report a new data point every five seconds (with the default configuration settings). Basically if the LCD screen is showing values, they ought to be getting to the internet.


#6

Hi Vic,

Many thanks for your help so far. I have registered the egg on your website and have the following web page for my device:

http://airqualityegg.com/egg/1966116191

In addition, there is an xively webpage.

However, the device does not seem to be posting anything, even though it has been operational for a few hours, it has connected to my home network, there are numbers shown on the LCD screen and you have mentioned the egg is publishing data to the opensensors.io server. Is the egg operating normally, and if it is, should there be number displayed on the airqualityegg.com website and graphs of data shown on the xively webpage? Currently there appears to be no data traffic. In addition, when I search for my egg on the google earth widget on the airqualityegg.com website, a placemark does not exist. I don’t understand why a placemark does not exist.

I ran the ‘get settings’ from the console interface and got the following details just in case any of these parameters can help indicate what the problem (if there is one) is:

AQE>: get settings
±------------------------------------------------------------+
| Preferences/Options: |
±------------------------------------------------------------+
Operational Mode: Normal
Temperature Units: Celsius
Altitude: Not set
Backlight Settings: 60 seconds, ON at startup
Sensor Sampling Interval: 5 seconds
Sensor Averaging Interval: 160 seconds
Sensor Reporting Interval: 5 seconds
±------------------------------------------------------------+
| Network Settings: |
±------------------------------------------------------------+
MAC Address: 70:FF:76:03:1F:6B
Method: Direct Connect
SSID: scoobydo
Security Mode: WPA2
IP Mode: Configured for DHCP
Update Server: update.wickeddevice.com
Update Filename: aqev2_no2_co
±------------------------------------------------------------+
| MQTT Settings: |
±------------------------------------------------------------+
MQTT Server: opensensors.io
MQTT Port: 1883
MQTT Client ID: eggxxxxxxxxxxxxx (changed just in case this should be private - please tell me if I am being paranoid!)
MQTT Authentication: Enabled
MQTT Username: wickeddevice
±------------------------------------------------------------+
| Credentials: |
±------------------------------------------------------------+
MQTT Password backed up? [* means no]
Private key backed up? [* means no]
±------------------------------------------------------------+
| Sensor Calibrations: |
±------------------------------------------------------------+
NO2 Sensitivity [nA/ppm]: 37.629997253
NO2 Slope [ppb/V]: 75927.265625000
NO2 Offset [V]: -0.829361629
CO Sensitivity [nA/ppm]: 5.989999771
CO Slope [ppm/V]: 476.985504150
CO Offset [V]: -1.997695922
Temperature Reporting Offset [degC]: 3.10
Humidity Reporting Offset [%]: -5.50
±------------------------------------------------------------+
| note: ‘*’ next to label means the setting is not backed up. |
| run ‘backup all’ when you are satisfied |
±------------------------------------------------------------+

Thanks
Robbie


#8

Something appears to be up with Xively. The data is flowing in and out of OpenSensors.io as expected… I’m working on it.


#9

@robbiegregg Seems like maybe I’ve solved it for the time being. Lets see if it holds up over a longer period of time. If you’re interested we’re repeating the data from OpenSensors to Xively to maintain a sort of continuity within the community, but as OpenSensors capabilities mature, this ‘bridge’ will hopefully become un-necessary.


#10

After a lot of IP problems which I resolved by setting a static IP address I have finally got my AQE2 to occassionally connect to the MQTT server, but it won’t register - egg008028edffab0111 - could you try giving the system a nudge? Thanks!


#11

Hi @Alex_van_Someren, I’ve just added your Serial Number to Xively, should work now… I’m scratching my head a bit because I was pretty sure Eggs weren’t getting boxed without this step happening, but I won’t panic just yet :smile:. Give that a try and let me know if you have any trouble.


#12

I also cannot seem to get my egg to register, and it also is in a firmware update loop, faling to update.

where should I get started? SN or Firmware?


#14

Hi @Kevin_McGough, please can you email your Egg serial number to support at wickeddevice dot com, reference this forum post and we’ll try and help sort you out there?