Devices are not seeing the Wi-Fi (ssid) - Can't configure


#1

I am testing two out of 12 pieces (both have the data logger option installed). Both are not seeing my Wi-Fi.
There is one initialization failure that I am not sure if related. I tried changing both Chrome and FireFox, changed router wireless security to wpa2, rebooted router, changed ssid and restarted pc. No change.
Thanks.
Here’s relevant info (dust devce, serial: *********b0130)

Info: RTC Initialization…OK.
Info: ESP8266 Initialization…Failed.
Enter ‘aqe’ for CONFIG mode.

AQE>: exit
Exiting CONFIG mode…
-~=
In OPERATIONAL Mode *=~-
Info: Beginning Network Scan…
Info: Network Scan found 0 networks
Info: Found Access Point “AbuMajdi2”, Not Found.
(display also reads: scanning wi-fi not found).


#2

Hi @AbedKhooli, I think you are actually experiencing a problem with the Web-based serial monitor. Please can you try with a different terminal program (e.g. Arduino, PuTTY, etc.). If you need more detailed support along these lines please let me know. Looking forward to hearing your results.

You should definitely not see the message: Info: ESP8266 Initialization…Failed.


#3

Thanks. That makes a great difference after a long struggle. Used PuTTY and connected to com ports I saw in the browser interface. ESP8266 Initialization… OK and access point recognized. I am getting some real readings now!


#4

Cool, I’ll have to chat with the guys at Code Bender about the embedded Web serial monitor problem. On an unrelated note, check out the article I published last night about Offline mode. http://shop.wickeddevice.com/2016/09/29/air-quality-egg-offline-mode-ftw/


#5

Very helpful blog. I did not test offline mode yet, but tried to add egg at http://airqualityegg.com/egg/353394807 and I am not seeing any readings (this is PM actually, so I guess that server is asleep). I verified data is online (viz and download) but also could not claim it at opensensors (it did not like the location). It is at Lat: 31.898 Lon: 35.197 - are +ve coordinates still problematic?


#6

@AbedKhooli registering your Egg at airqualityegg.com pretty much just puts the Egg on the map. We have been working on restoring the dashboard type of capability, but it’s not linked to airqualityegg.com currently. I would encourage you to check out https://airqualityegg.wickeddevice.com/dashboard/#/egg/your-egg-serial-number for some beta development we’ve been doing to that end, and you can leave off the part after dashboard to see a map (which I’m synchronizing with airqualityegg.com manually for the moment). I’ll have to check on Monday to find out why you’re having problems claiming at OpenSensors.io, but really, unless you’re going to write your own software, you shouldn’t need to do that. I don’t think I’ve ever heard of a problem with sign of geographic coordinates, but you might try asking a question at http://support.opensensors.io,


#7

The dashboard at https://airqualityegg.wickeddevice.com/dashboard/#/egg/egg00802… is working great since yesterday (the only glitch I noticed so far is the need to try several times to catch the interval drop down values). Nothing on map yet (at aqe.wd).
I am sharing 2 screenshots of the attempt to claim this device

(before and after) submit. The default Longitude is zero and they may be calculating offsets.


#8

Replying to myself here as an update: Viz at https://airqualityegg.wickeddevice.com/dashboard/#/egg/egg00*********** stopped working. Not sure if http://support.opensensors.io is working well (sign up say acct suspended - never created, only publisher account exists). Still can’t claim device as above. Plan is to control up to 10 devices from one interface page.


#9

@AbedKhooli hm, please can you try their contact form by clicking on Contact in the upper right hand corner of https://opensensorsio.helpscoutdocs.com/?


#10

Emailed opensensors.
What about data viz at https://airqualityegg.wickeddevice.com/dashboard/#/egg/egg0******** ? Still not working.
Also, interested to see how data imputation is implemented (occasionally missing data points, logged as —).
*** edit: I clicked Reset Lat/Lon on opensensors form and claimed devices without location. Not sure what magic behind that link but worked.


#11

I just checked on the server and ya things had gotten stuck on the dashboard. I just restarted that process so it should work again now. There’s obviously some server-side bug that I haven’t trapped yet.

You can look at the download tool source code here. The code that pulls data from OpenSensors.io is all contained in this file, and the code that stitches the data from the different sensors together is located in these lines of code. I think it does a pretty good (much better) job of aligning the data records in time since I updated it 12 days ago, I’ll probably re-write the whole download tool again at some point in the future to be less RAM intensive. If you are interested, the code for the experimental dashboard is also available for review here.


#12

Are processes allocated per device on the server? I see one device visualizer working and the other stopped/stuck. If device owners can’t recycle a stuck process, may be scheduling a recycle (ex. twice per day) would work until problem is fixed.


#13

@AbedKhooli not really, it’s more like there is a request queue and sometimes things die in the queue and clog it up. However, at the moment there doesn’t appear to be any evidence that is happening. Rather, one of the Eggs being requested by a dashboard is consistently returning zero results from Open Sensors. That would seem to imply that either that device is not online (or hasn’t reported data in the last 10 seconds) currently, or the serial number being requested is not a legitimate serial number. Please can you check on the one that ends in b0130?


#14

b0130 is OK (can select duration and see results, self update not fully functional). The one that is completely stuck is 90133. I can see it posting events to opensensors but is stuck (since yesterday) on the dashboard at https://airqualityegg.wickeddevice.com/dashboard/#/egg/egg*******90133


#15

Hm yes I see what you mean. That is wierd because there is certainly data that I can get using the download tool, it just seems like the dashboard tool is in a weird state that I don’t quite understand. I’ll restart it and see if that fixes it.


#16

So, yea that fixed it insofar as it at least made the initial data request and displayed self-updating plots. As you suggested earlier, maybe for now I should just add a cron job to restart the dashboard process every 15 minutes.


#17

OK, I’ve just done that so lets see how it goes…


#18

I see it working, thanks. For the duration drop down, I suggest to set the default to 1 hr (instead of 5 min, a balance of load/usability) - unless 5 min was selected based on usage trends.