Corrupt firmware detected

My new AQ egg was working fine for a few days, left outside to grab data. This is the weatherproof model.

I checked the web portal and found my AQ egg last showed data 13 hours ago.
The screen said “touch to setup or connect to usb.”

I connected to my PC to try to update the WiFi info again, that worked.

I disconnected from my PC and plugged in to usb power.
Screen booted and connected to wifi but then stopped at “corrupt firmware detected.”

I connected to my PC to try to update firmware.
The firmware updated looking at the serial output, but the configurator screen said failures.

It went on a loop and never completed. Now I am afraid it is bricked.

Note when I first received the Egg, I tried to update the firmware to make sure it was the latest. If I recall it completed with either errors or warnings - I did not screenshot those.

We resolved this issue over a phone call. It turned out that partially complete firmware update apparently left the Egg in a peculiar state in which it was not possible to enter configuration mode. The solution was ultimately to reprogram the Egg over USB and restore it to the appropriate firmware via an over-the-air update.

The Egg is able to perform unattended updates, and it checks for them during it’s power-on self-testing sequence. While the Serial Configurator application supports invoking a over-the-air firmware update manually, it’s really only meant for unusual circumstances. As a matter of course, most users should not need to use that functionality.