Angular Clock dead after working fine for 1 year: No lights. How to debug?


#1

My Angular Clock v2 has worked properly since I assembled it about a year ago. Now, it’s completely dead. There are no lights. I’ve tried a different power source (USB), and tested the backup battery (still over 3V). Reset has no effect. I saw the similar topic and tried wiggling the USB connector, but this had no effect.

If the processor isn’t working, would it give this symptom? Or is this likely a power regulator or other power-specific problem.

I’d appreciate any suggestions for getting the clock going again.

Thanks!

Dick


#2

Hi Dick, does it print anything out to the Serial Monitor if you plug the USB into your computer? How comfortable are you with a multimeter? You should be able to measure something near 5V across pins 2 and 6 of the ICSP header (the two outermost pins along the short edge of the board) with power plugged in by USB.

The electronics are pretty robust, my bet would be the wall power supply or the USB connector. If you have a 5V USB phone charger, you could try plugging that into the USB port. If it’s the board failed for some reason, we do sell it ala cart if you want to try replacing it.


#3

Thank you for your prompt and helpful reply.

I’ve tried a couple of power supplies, as well as the USB port on my PC. I get the usual Windows bub-unk chime when plugging the USB, and a port appears in the Arduino IDE Port menu. Selecting that port and resetting the clock produces no output in the serial monitor. The voltage on the two pins you asked about, with the unit plugged into my PC, is 4.95V.

Again, there are no LEDs lit on the board. I checked, and it’s actually been 2 years since I bought the board, and since it’s been operating properly.

Unless you have another idea, it appears that I need to replace the board. What’s the price for the replacement? (I can unsolder the components that were attached with the kit, if they don’t come with the replacement board, as you advise. I don’t remember what pieces, if any, were soldered on during construction.)

Thanks again!

Dick


#4

Interesting, in that case, you could try reprogramming it with Arduino using the sketch from https://github.com/wickeddevice/angularclock. I can’t imagine how it might have lost its programming load, but it’s worth a shot.


#5

Thanks for your idea. Unfortunately, no upload is possible. I get “Programmer is not responding” errors.

This didn’t surprise me, as there is no LED lit on the board. My recollection is that there is a power LED that should be on.

In any event, there’s power, and the USB chip is responding, but I’m not able to get the attention of the Arduino CPU.

Is there anything else I can measure or try before we replace the board?

Thanks,

Dick


#6

In Arduino, did you select Arduino Uno as the board and then select the COM port associated with the Angular Clock board from the Ports menu (it won’t appear in the menu unless you have USB from your computer plugged into the Angular Clock)?


#7

Thanks. Progress. I had the wrong Arduino set. I downloaded the AngularClock code and the libraries, and loaded them into the IDE. The result doesn’t compile. I’ll include some of the errors below.

Just to see whether I was getting anywhere, I loaded a simple program into the clock (Blink). The IDE says it loaded, but there’s no blinking LED. Perhaps it’s not the right pin. The good news is that I seem to be able to load programs into the clock.

Here is some of the error message result of trying to compile the clock code:


AngularClock:60: error: ‘tmElements_t’ does not name a type

tmElements_t tm;

^

C:\Users\Dick\Desktop\AngularClock-master\AngularClock\AngularClock.ino: In function ‘void show_time_tm(char*)’:

AngularClock:73: error: expected primary-expression before ‘.’ token

Serial.print(tm.Hour, DEC);

              ^

AngularClock:75: error: expected primary-expression before ‘.’ token

Serial.print(tm.Minute, DEC);

              ^

AngularClock:77: error: expected primary-expression before ‘.’ token

Serial.print(tm.Second, DEC);

              ^

C:\Users\Dick\Desktop\AngularClock-master\AngularClock\AngularClock.ino: In function ‘void setup()’:

AngularClock:204: error: expected primary-expression before ‘.’ token

rtc.getDateTime(&tm.Second,&tm.Minute,&tm.Hour,&tm.Wday,&tm.Day,&tm.Month,&tm.Year);


Am I missing a library or some other piece? I downloaded the three libraries as ZIP files, and installed them. I also downloaded the clock stuff as a ZIP, extracted the .ino file, and opened that. (I also tried it opening the .ZIP, and got the same result. That seems to be the only code in the set of files.)

I’m still learning the Arduino IDE. I’d appreciate your further help in getting the clock code reloaded.

Thanks again!

Dick


#8

One thing that I have found if that the USB cable provided has a tendency of not making proper contact with the connector on the cpu board itself. I found myself with a similar problem up front and used a like but different cable of better quality and it has worked fine since.


#9

You probably haven’t got the libraries installed in the right place or in the right way. In Arduino’s File => Preferences you’ll see “Sketchbook Location” which designates a folder where Arduino fishes for stuff. In that folder you should have a directory structure that looks like this (folder names are important here):

/libraries
     /Time
          /examples
          Time.h
          Time.cpp
          etc...
     /Encoder
          /utility
          /examples
          Encoder.h
          Encoder.cpp
          etc...
     /MCP7941x
          /examples
          MCP7941x.h
          MCP7941x.cpp
          etc...

#10

Thanks for the suggestion. The libraries looked right (except that the Time library is called Time-master), but I uninstalled the Arduino IDE and reinstalled it. I loaded the clock code and the three libraries from GITHUB, as specified in the entry for the Angular Clock entry. I still get this compilation error:

AngularClock:60: error: ‘tmElements_t’ does not name a type

tmElements_t tm;

^
I’m frustrated. What am I doing wrong here? One way or the other (even with a new cable, which I don’t think is the problem), I’m going to need to reload the clock code, so I’m stuck.

Dick


#11

Thank you for your reply. Since I found 5V on the board, and was able to upload a simple program to the card, I doubt that the problem is the cable in my case. I’ll get another cable, in any event, and try it. I appreciate the suggestion.

Dick


#12

Did you try renaming the “Time-master” folder to just “Time”, restarting Arduino, then trying to compile again? What version of Arduino are you running, maybe you’re using a newer one than me and something has changed?


#13

Thanks for staying with me on this. I renamed the library folder to Time, and restarted the IDE, but it made no difference. I’m running the latest IDE, Version 1.82.

I take it that you are able to compile the code using the three specified libraries. I see that “tmElements_t” is used inside the timelib code, but I’m not sure what this means in terms of it not being understood in the angularclock code.

Dick


#14

I tried compiling the angularclock code with the online compiler, and it compiled. A step forward. Clearly, there’s something wrong with my IDE setup. I’ll try loading the clock with the code again, later today. Thanks agin for your help with this.


#15

I’m delighted to report that the Angular Clock loaded properly with the program, and is working correctly now. It’s still a puzzle why the IDE failed to compile on both my PC and Mac, but the online version compiled and loaded.

Thank you for your help and persistence in getting my clock working again!

Dick


#16

Bravo! Well done, glad we could help you out!